User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2021
    Location
    Baltimore, MD
    Posts
    19
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Low Oil Alarm - 2.5 EFI

    I have a low oil alarm but the engine mounted tank is full. If I disconnect the wires to the sensor shouldn't the alarm stop? It doesn't for me.

    t i a

  2. #2
    Join Date
    Feb 2009
    Location
    Edgewater,B.C. CANADA
    Posts
    8,127
    Thanks (Given)
    152
    Thanks (Received)
    293
    Likes (Given)
    3242
    Likes (Received)
    1154
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    steady beep or beep, beep ,beep?

    Dave
    1980 Cougar 19 tunnel,90 2.4L Bridgeport EFI in middle of restoration.
    1988 BAJA Sunsport 186, 96 225 Pro Max
    79 12' Auminum, 95 Merc 9.9
    RIP Stu
    "So many idiots, so few bullets"

  3. #3
    Join Date
    Sep 2021
    Location
    Baltimore, MD
    Posts
    19
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Dave Strong View Post
    steady beep or beep, beep ,beep?

    Dave
    4 beeps every two minutes. The tank on the engine is full. I took the sensor out and disconnected the wires from the engine. I figured that would stop the alarm but it didn't. Then I jumped the two wires on the engine, still got the alarm. Took the sensor and hooked it to an ohm meter and ran a magnet up and down the sensor. Got continuity until the magnet reached the top so the sensor seems to be fine.

  4. #4
    Join Date
    Feb 2009
    Location
    Edgewater,B.C. CANADA
    Posts
    8,127
    Thanks (Given)
    152
    Thanks (Received)
    293
    Likes (Given)
    3242
    Likes (Received)
    1154
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Another Tricky Day View Post
    4 beeps every two minutes. The tank on the engine is full. I took the sensor out and disconnected the wires from the engine. I figured that would stop the alarm but it didn't. Then I jumped the two wires on the engine, still got the alarm. Took the sensor and hooked it to an ohm meter and ran a magnet up and down the sensor. Got continuity until the magnet reached the top so the sensor seems to be fine.
    Could be the plastic gear on the crank is worn and not turning the pump there is a rotation sensor. When the pump is not turning or turning sometimes will sound the alarm.

    Dave
    1980 Cougar 19 tunnel,90 2.4L Bridgeport EFI in middle of restoration.
    1988 BAJA Sunsport 186, 96 225 Pro Max
    79 12' Auminum, 95 Merc 9.9
    RIP Stu
    "So many idiots, so few bullets"

  5. #5
    Join Date
    Jul 2006
    Location
    Wisconsin
    Posts
    3,426
    Thanks (Given)
    454
    Thanks (Received)
    384
    Likes (Given)
    4989
    Likes (Received)
    3703
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Seems to me the tank on the motor had to be full full... like up into the filler neck full???
    (Never really looked at the motor tank until I had an alarm I couldn't figure out.)

    Also, the alarms don't go on or off right away... you could see the fault on the DDT for about 2 minutes before the alarm would start beeping (so you don't get a lot of false alarms in rough water or whatever; according to the engineers at Merc). You would have to (probably) wait after jumpering or disconnecting the wires?
    Last edited by David - WI; 09-19-2021 at 03:36 PM.
    Joke Biden is NOT my potato! .

  6. #6
    Join Date
    Sep 2021
    Location
    Baltimore, MD
    Posts
    19
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The tank is full full. I've had it go low before a few times and have had to purge and fill he tank so I am confident it up to the proper level. Thanks

  7. #7
    Join Date
    Sep 2021
    Location
    Baltimore, MD
    Posts
    19
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My pump is not mechanical but rather electronic. However I do intend to check oil flow out of the pump. Thanks

Similar Threads

  1. oil alarm ????????
    By mragu in forum Technical Discussion
    Replies: 22
    Last Post: 06-12-2015, 08:53 PM
  2. 300 pro max alarm
    By skaterjim in forum Technical Discussion
    Replies: 2
    Last Post: 05-07-2010, 05:26 AM
  3. Mercury Tech: Oil Alarm ... WHY??
    By WOT RACING in forum Technical Discussion
    Replies: 3
    Last Post: 06-28-2009, 10:27 AM
  4. Mercury Tech: 115 HP Alarm
    By EdS in forum Technical Discussion
    Replies: 1
    Last Post: 04-30-2009, 08:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Aeromarine Research