User Tag List

Page 4 of 4 FirstFirst 1 2 3 4
Results 46 to 54 of 54
  1. #46
    Join Date
    Sep 2008
    Location
    charlestown, ri
    Posts
    206
    Thanks (Given)
    0
    Thanks (Received)
    1
    Likes (Given)
    0
    Likes (Received)
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    no worries but that clear sleeve is critical! make fuel happen a smidge earlier. for the timer base test: i rarely bother with resistance anymore. i go right to cranking voltage. anything over .3v on each of the power wires and it is enough to trigger the pack. make sure all of your ignition coil grounds are clean and shiny, both on the coil ground tabs, and on the bosses on the block.

  2. #47
    Join Date
    Aug 2021
    Location
    stamford, CT
    Posts
    53
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    4
    Likes (Received)
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Revenge22 View Post
    no worries but that clear sleeve is critical! make fuel happen a smidge earlier. for the timer base test: i rarely bother with resistance anymore. i go right to cranking voltage. anything over .3v on each of the power wires and it is enough to trigger the pack. make sure all of your ignition coil grounds are clean and shiny, both on the coil ground tabs, and on the bosses on the block.
    revenge 22, theres supposed to be a clear tube on this?Click image for larger version. 

Name:	20211021_171723.jpg 
Views:	18 
Size:	434.0 KB 
ID:	495077
    Attached Thumbnails Attached Thumbnails 20211021_121544.jpg  
    Last edited by joeymcgovs; 10-21-2021 at 04:24 PM.

  3. #48
    Join Date
    Jul 2005
    Location
    AZ
    Posts
    2,684
    Thanks (Given)
    319
    Thanks (Received)
    204
    Likes (Given)
    4706
    Likes (Received)
    2258
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    No clear tube...but the black roller Unless maybe someones replaced the black with it ..
    So no you're not missing anything there.
    Looking for a better pic if thats not good
    Click image for larger version. 

Name:	Screenshot_20211021-144514.png 
Views:	15 
Size:	1.85 MB 
ID:	495080

    Actually have seen some that were translucent but
    LETS GO BRANDON.... LETS GO BRANDON

    Sometimes I talk to myself...then we both just laugh and laugh

    '84 Checkmate Convincor
    Twin v6 closed deck Evinrude loopers Ported,2.7 heads,cooling mods
    milled finger ported to match vertex pistons,
    All casting slag removed
    Sleeves in opposite so no idle reliefs
    Offshore exhaust mids
    152 psi comp,balanced pistons and rods,Stuffed, 106 pullovers
    CDI 8500 digital ignitions ..Boyesen reeds..And more..

  4. Likes joeymcgovs liked this post
  5. #49
    Join Date
    Aug 2021
    Location
    stamford, CT
    Posts
    53
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    4
    Likes (Received)
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thats a pretty sweet flywheel

  6. #50
    Join Date
    Jul 2005
    Location
    AZ
    Posts
    2,684
    Thanks (Given)
    319
    Thanks (Received)
    204
    Likes (Given)
    4706
    Likes (Received)
    2258
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Little color after doing the rest of the motor.. lol
    LETS GO BRANDON.... LETS GO BRANDON

    Sometimes I talk to myself...then we both just laugh and laugh

    '84 Checkmate Convincor
    Twin v6 closed deck Evinrude loopers Ported,2.7 heads,cooling mods
    milled finger ported to match vertex pistons,
    All casting slag removed
    Sleeves in opposite so no idle reliefs
    Offshore exhaust mids
    152 psi comp,balanced pistons and rods,Stuffed, 106 pullovers
    CDI 8500 digital ignitions ..Boyesen reeds..And more..

  7. Likes joeymcgovs liked this post
  8. #51
    Join Date
    Sep 2008
    Location
    charlestown, ri
    Posts
    206
    Thanks (Given)
    0
    Thanks (Received)
    1
    Likes (Given)
    0
    Likes (Received)
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it looks too thin to me... the o ring is almost the diameter of the roller. the clear part sticks out on the sides a bit more but hard to tell without side by side.

  9. #52
    Join Date
    Aug 2021
    Location
    stamford, CT
    Posts
    53
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    4
    Likes (Received)
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i ordered a new roller when i ordered the carb kits, i am going to put the new roller on today, and try a lync and sync again

  10. #53
    Join Date
    Aug 2021
    Location
    stamford, CT
    Posts
    53
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    4
    Likes (Received)
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thank you all that have responded! i now have another update!...

    so i did the lync and sync, well i did all the steps up until the parts you have to do in the water, (water test and finish sync is tomorrow) and at first the engine would not start, it would crank and fire, but would not fire up... so after some investigating i found out i was not getting good spark, i pulled on the ground wire that comes off power pack to a ring connector and grounds to the engine behind the #1 coil top bolt and the wire broke loose from the ring connector, so i skinned the wire back, cleaned it up and put a new heat shrink ring connector on... still weak spark on all 4 intermittently, sometimes only 2 spark plugs were actually sparking... these are brand new cdi coils... so i decided to put my original evinrude coils back on and spark was phenomenal on all 4... so i put the spark plugs back in, turned the key, and BAM! engine fired up immediately! like it never has before, i didnt even have the cold start lever up at all... so i let it run, engine came up to temp, and idled down to a nice 900-1000k (i have the engine in a 55 gallon barrel on its side, full of water to a little bit over the cavitation plate.) she continue to idle great, no roughness at all, no hesitation, and NO MORE SNEEZING!! i know i have to check ignition timing in the water, in gear, tied to the dock, but i figured i would try my timing light anyway and it was pretty close to the omc idle spec of 8 degrees after top dead center. so it seems like i am ready for the next water test!!

    however, after all of this i decided to see if my primer bulbs stays hard after i pump it up... it does not.. i can pump the bulb, it will get hard, but if jump out of the boat, walk around the boat and jump back in i can pump the bulb again as if i never pumped it.... although, even if i dont pump it again and its not hard anymore, the engine still fires right up with just a bump of the ignition key and will stay running... not sure why the bulb wont stay hard? maybe the bulb is bad? possible leak somewhere? my real question is should i not water test knowing the bulb does not stay hard? would this condition make the engine run lean?? again, any help would be greatly appreciated! trying to get this sorted out while i can still water test

  11. #54
    Join Date
    Aug 2021
    Location
    stamford, CT
    Posts
    53
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    4
    Likes (Received)
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    update*** put the tahiti in the water today and it ran pretty flawless... fired up immediately without the need of the rev arm on the control box, and i didnt even push the key in. engine was consistent the entire hour i was out there, every time i gave it wide open throttle rpms shot to 6k, anytime i brought it down to idle speed or even putting it in neutral, engine idled great! never stalled once!

    i checked ignition timing while tied to the dock in gear at idle, it was just a hair off from the 8 degreees atdc, i wanted to adjust it but felt like i was splitting hairs with how close it is... so say it was at 6 or 7 degrees atdc, if i bumped it to 8 degrees atdc that would be retarding the timing right? and say it was at 10 dgerees atdc and i brought it back to 8 degress that would be advancing right? or do i have that backwards?

    the only place i felt the engine wasnt a full 100% was between 1500 and 2000 rpms, although i am not familiar with how its supposed to feel at those rpms it just seemed like it wasnt as smooth, although the engine wasnt shaking or anything, people have told me these engines are rougher then others at lower rpms, but it didnt bother me, just want to make sure i have this engine 100%. from 1500 rpms or less or 2000 rpms or more evrything is smooth as butter, i think i am over thinking the slight roughness between 1500 and 2000 rpms. in all honesty i am extremely happy with the way the boat and engine performed.

    thank you to everyone who has helped me out, if anyone is ever in the stamford/greenwich/port chester area id be more then happy to take you for a ride on the sound in a Tahiti kind of way

Page 4 of 4 FirstFirst 1 2 3 4

Similar Threads

  1. 18' Tahiti $800
    By noli in forum Ebay Listings and Other Internet Listings
    Replies: 0
    Last Post: 06-18-2016, 01:11 PM
  2. My Tahiti
    By Tahiti Steve in forum General Boating Discussion
    Replies: 14
    Last Post: 08-04-2012, 09:59 AM
  3. Need help with a TAHITI
    By PhatBC0182 in forum General Boating Discussion
    Replies: 10
    Last Post: 08-09-2010, 02:42 PM
  4. Tahiti?
    By boatnut62 in forum General Boating Discussion
    Replies: 0
    Last Post: 05-20-2009, 01:04 AM
  5. 1990 90 hp Evinrude for 16 ft tahiti?
    By iowamcnabb in forum General Boating Discussion
    Replies: 9
    Last Post: 03-19-2007, 08:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Frank Mole Transport