User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18
  1. #1
    Join Date
    Apr 2001
    Location
    Michigan
    Posts
    12,829
    Thanks (Given)
    70
    Thanks (Received)
    186
    Likes (Given)
    2691
    Likes (Received)
    1646
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Good start to the year

    Nothing like a good old fashioned Mercury voltage regulator fire. . At least it happened on the water and didn't burn my ****ing house down. Click image for larger version. 

Name:	IMG_20180526_224202_01.jpg 
Views:	174 
Size:	321.7 KB 
ID:	408600

  2. Likes Tom Foley liked this post
  3. #2
    Join Date
    Aug 2012
    Location
    beaumont, tx
    Posts
    1,808
    Thanks (Given)
    117
    Thanks (Received)
    57
    Likes (Given)
    737
    Likes (Received)
    445
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    dammit boy!
    81' HYDROSTREAM VECTOR / slightly Modified 200
    before and after:http://www.screamandfly.com/showthre...inished!/page3


  4. #3
    Join Date
    Oct 2002
    Location
    PARADISE /Naples
    Posts
    2,731
    Thanks (Given)
    2
    Thanks (Received)
    33
    Likes (Given)
    19
    Likes (Received)
    234
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did you have to piss on it.
    We have invented the world WE see

  5. #4
    Join Date
    Jun 2003
    Location
    minocqua, wis
    Posts
    2,916
    Thanks (Given)
    3
    Thanks (Received)
    48
    Likes (Given)
    115
    Likes (Received)
    253
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Nothing good about that sounds like last summer for me looking at your pic fire sucks

  6. #5
    Join Date
    Feb 2009
    Location
    Edgewater,B.C. CANADA
    Posts
    7,228
    Thanks (Given)
    93
    Thanks (Received)
    152
    Likes (Given)
    1794
    Likes (Received)
    665
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well that just sucks!

    Dave
    1980 Cougar 19 tunnel,90 2.4L Bridgeport EFI in middle of restoration.
    1988 BAJA Sunsport 186, 96 225 Pro Max
    79 12' Auminum, 95 Merc 9.9
    RIP Stu
    "So many idiots, so few bullets"

  7. #6
    Join Date
    Feb 2015
    Location
    Ontario
    Posts
    4,357
    Thanks (Given)
    105
    Thanks (Received)
    132
    Likes (Given)
    1004
    Likes (Received)
    809
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Use to be white? Sorry man!

  8. #7
    Join Date
    Apr 2001
    Location
    Michigan
    Posts
    12,829
    Thanks (Given)
    70
    Thanks (Received)
    186
    Likes (Given)
    2691
    Likes (Received)
    1646
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by FMP View Post
    Use to be white? Sorry man!
    Racist.

  9. #8
    Join Date
    Feb 2015
    Location
    Ontario
    Posts
    4,357
    Thanks (Given)
    105
    Thanks (Received)
    132
    Likes (Given)
    1004
    Likes (Received)
    809
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I'm guessing no fuse or fusible links, damm mess.

  10. #9
    Join Date
    Apr 2001
    Location
    Michigan
    Posts
    12,829
    Thanks (Given)
    70
    Thanks (Received)
    186
    Likes (Given)
    2691
    Likes (Received)
    1646
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    They are fused.

  11. #10
    Join Date
    Feb 2009
    Location
    Edgewater,B.C. CANADA
    Posts
    7,228
    Thanks (Given)
    93
    Thanks (Received)
    152
    Likes (Given)
    1794
    Likes (Received)
    665
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Capt.Insane-o View Post
    They are fused.
    guess they need to fuse the stator side as well.

    Dave
    1980 Cougar 19 tunnel,90 2.4L Bridgeport EFI in middle of restoration.
    1988 BAJA Sunsport 186, 96 225 Pro Max
    79 12' Auminum, 95 Merc 9.9
    RIP Stu
    "So many idiots, so few bullets"

  12. #11
    Join Date
    Apr 2001
    Location
    Michigan
    Posts
    12,829
    Thanks (Given)
    70
    Thanks (Received)
    186
    Likes (Given)
    2691
    Likes (Received)
    1646
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Sucks, I really like the motor and don't want to alter it in anyway but this particular issue with regulator motors is all to common. Plus it was a squeaky clean motor and cleaning it back up is going to be a pain in the ass.

  13. Likes Dave Strong liked this post
  14. #12
    Join Date
    Feb 2009
    Location
    Edgewater,B.C. CANADA
    Posts
    7,228
    Thanks (Given)
    93
    Thanks (Received)
    152
    Likes (Given)
    1794
    Likes (Received)
    665
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I replaced the yellow potted ones on my Pro Max a few years ago with the new fused style. Was hoping that was going to be the end of my regulator issues.

    Dave
    1980 Cougar 19 tunnel,90 2.4L Bridgeport EFI in middle of restoration.
    1988 BAJA Sunsport 186, 96 225 Pro Max
    79 12' Auminum, 95 Merc 9.9
    RIP Stu
    "So many idiots, so few bullets"

  15. #13
    Join Date
    Jul 2003
    Location
    Hudson , Fl.
    Posts
    10,692
    Thanks (Given)
    39
    Thanks (Received)
    109
    Likes (Given)
    1545
    Likes (Received)
    748
    Mentioned
    2 Post(s)
    Tagged
    2 Thread(s)
    That's why you need a 260 16 amp , no regulator !!
    " The Fleet of Old Boats "
    '71 -16' Super Sidewinder -140 Mercruiser )
    '73 -14' Orlando Clipper Skiff -Yamaha 25
    '79 - 21' Mako -Yamaha -200 EFI
    93- 18 ' Renegade Nomad Flats boat -Merc 150
    '94 - 21 ' Allison XB - 2003 -Merc 260
    '97 - 19 ' STV Euro - Merc - 260
    '99 Benninton 2375 TOONER - V-6- 2 liter 150 Mariner


    http://www.srwmd.state.fl.us/index.aspx?nid=105
    IMPEACH OBAMA - REMEMBER BENGHAZI ..NEVER FORGET !!!!!!!!

  16. #14
    Join Date
    Feb 2015
    Location
    Ontario
    Posts
    4,357
    Thanks (Given)
    105
    Thanks (Received)
    132
    Likes (Given)
    1004
    Likes (Received)
    809
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Dave Strong View Post
    guess they need to fuse the stator side as well.

    Dave
    If you could get it to kill ign at first sign of breakdown , open switch to battery

  17. #15
    Join Date
    Feb 2009
    Location
    Edgewater,B.C. CANADA
    Posts
    7,228
    Thanks (Given)
    93
    Thanks (Received)
    152
    Likes (Given)
    1794
    Likes (Received)
    665
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Tom Foley View Post
    That's why you need a 260 16 amp , no regulator !!
    I have a Bridgeport with that system.

    Dave
    1980 Cougar 19 tunnel,90 2.4L Bridgeport EFI in middle of restoration.
    1988 BAJA Sunsport 186, 96 225 Pro Max
    79 12' Auminum, 95 Merc 9.9
    RIP Stu
    "So many idiots, so few bullets"

  18. Likes Tom Foley liked this post
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Mercury Tech: 260 big bearing?? what year did they start production
    By jas638 in forum Technical Discussion
    Replies: 17
    Last Post: 05-02-2016, 12:39 PM
  2. What year did Merc start with the 200 Pro XS?
    By mxz in forum Four Stroke and Direct Injected Two Stroke Engines
    Replies: 2
    Last Post: 05-12-2014, 07:17 PM
  3. What year did top pinning start?
    By stoneman in forum Technical Discussion
    Replies: 2
    Last Post: 06-24-2007, 10:13 AM
  4. What year V8 is the best to start a performance build up on?
    By neveredge in forum Technical Discussion
    Replies: 1
    Last Post: 08-30-2006, 08:00 AM
  5. Whats a good small business to start up that pays good?
    By WATERWINGS in forum The Scream And Fly Lounge
    Replies: 36
    Last Post: 11-25-2003, 01:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Chris Carson's Marine