User Tag List

Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    218
    Thanks (Given)
    0
    Thanks (Received)
    1
    Likes (Given)
    0
    Likes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    ETEC Diagnostic Kit - Want to order. Fault with motor not reving Etec 75Hp

    Hi Guys,

    Asking for a mate who has an etec that will not rev up in neutral or in gear. Throttle opens up but wont rev. He wants to order a diagnostics kit. Is this possible or does it need to be ordered through a dealer?

    Also any ideas what would cause this fault?

    Motor went under water while not running.

  2. #2
    Join Date
    May 2003
    Location
    Tarpon Springs, FL---Queens,NY
    Posts
    16,811
    Thanks (Given)
    121
    Thanks (Received)
    70
    Likes (Given)
    605
    Likes (Received)
    558
    Mentioned
    1 Post(s)
    Tagged
    2 Thread(s)
    Test the shift interrupt switch. It should be depressed in neutral. Also make sure the throttle is returning completely to idle or it will never let it rev.
    Quartershot T-3R 15" 3.5L E-Tec 1.62 Sportmaster


  3. #3
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    218
    Thanks (Given)
    0
    Thanks (Received)
    1
    Likes (Given)
    0
    Likes (Received)
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks heaps we will try this

  4. #4
    Join Date
    Apr 2005
    Location
    Canada, East!
    Posts
    518
    Thanks (Given)
    10
    Thanks (Received)
    11
    Likes (Given)
    304
    Likes (Received)
    50
    Mentioned
    0 Post(s)
    Tagged
    2 Thread(s)
    Under in salt water or fresh?

    pointer

  5. #5
    Join Date
    Sep 2014
    Location
    Florida keys
    Posts
    3
    Thanks (Given)
    0
    Thanks (Received)
    0
    Likes (Given)
    0
    Likes (Received)
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check the tps function also. You can do this by ohm check. I would also check all your harness connections for corrosion due to going underwater. have you done basic checks? Compression/spark? Flywheel key? Does you ecm have all 4 leds active when it's idling?

  6. Likes baja200merk liked this post

Similar Threads

  1. Why are ETec G2 H.O. Motors selling for less than the older Etec H.O.'s ?
    By Pachanga_rick in forum Four Stroke and Direct Injected Two Stroke Engines
    Replies: 48
    Last Post: 03-05-2016, 01:51 AM
  2. 75hp - 90hp Etec differences
    By Hevi Kevi in forum Four Stroke and Direct Injected Two Stroke Engines
    Replies: 3
    Last Post: 12-24-2014, 12:42 PM
  3. lost diagnostic software for my etec 150
    By mako23 in forum Technical Discussion
    Replies: 2
    Last Post: 07-24-2012, 06:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Diamond Marine